re = /revenue.{0,10}?\s(\d+(?:[.,%]\d+)*\s*\w*)/m
str = 'The company has a revenue of 2.7 Mio.
The company creates growing revenues and employs more than 25 employees.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end