import re
regex = re.compile(r"revenue.{0,10}?\s(\d+(?:[.,%]\d+)*\s*\w*)", flags=re.MULTILINE)
test_str = ("The company has a revenue of 2.7 Mio.\n"
"The company creates growing revenues and employs more than 25 employees.")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")