#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?xim)^" & @CRLF & _
"(?(DEFINE)(?<part>(?:xn--)?[a-z\d](?:[a-z\d-]*[a-z\d])?))" & @CRLF & _
"(?(DEFINE)(?<subpart>(?:xn--)?[a-z\d_](?:[a-z\d_-]*[a-z\d])?))" & @CRLF & _
"(?:(?&subpart)\.)*" & @CRLF & _
"(?&part)" & @CRLF & _
"(?:\.[a-z]+|\.xn--[a-z\d]+){1,2}" & @CRLF & _
"$"
Local $sString = "www.foo.bar.baz" & @CRLF & _
"www.foo.bar" & @CRLF & _
"foo.bar.baz" & @CRLF & _
"foo.bar" & @CRLF & _
"foo" & @CRLF & _
"xn--tst-qla.de" & @CRLF & _
"xn--tst-qla.xn--tst-qla.de" & @CRLF & _
"xn--tst-qla.xn--tstqla" & @CRLF & _
"ASPMX.L.GOOGLE.COM" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")