package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?xim)^
(?(DEFINE)(?<part>(?:xn--)?[a-z\d](?:[a-z\d-]*[a-z\d])?))
(?(DEFINE)(?<subpart>(?:xn--)?[a-z\d_](?:[a-z\d_-]*[a-z\d])?))
(?:(?&subpart)\.)*
(?&part)
(?:\.[a-z]+|\.xn--[a-z\d]+){1,2}
$`)
var str = `www.foo.bar.baz
www.foo.bar
foo.bar.baz
foo.bar
foo
xn--tst-qla.de
xn--tst-qla.xn--tst-qla.de
xn--tst-qla.xn--tstqla
ASPMX.L.GOOGLE.COM
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}