import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\n"
+ "(?(DEFINE)(?<part>(?:xn--)?[a-z\\d](?:[a-z\\d-]*[a-z\\d])?))\n"
+ "(?(DEFINE)(?<subpart>(?:xn--)?[a-z\\d_](?:[a-z\\d_-]*[a-z\\d])?))\n"
+ "(?:(?&subpart)\\.)*\n"
+ "(?&part)\n"
+ "(?:\\.[a-z]+|\\.xn--[a-z\\d]+){1,2}\n"
+ "$";
final String string = "www.foo.bar.baz\n"
+ "www.foo.bar\n"
+ "foo.bar.baz\n"
+ "foo.bar\n"
+ "foo\n"
+ "xn--tst-qla.de\n"
+ "xn--tst-qla.xn--tst-qla.de\n"
+ "xn--tst-qla.xn--tstqla\n"
+ "ASPMX.L.GOOGLE.COM\n";
final Pattern pattern = Pattern.compile(regex, Pattern.COMMENTS | Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}