const regex = /^
(?(DEFINE)(?<part>(?:xn--)?[a-z\d](?:[a-z\d-]*[a-z\d])?))
(?(DEFINE)(?<subpart>(?:xn--)?[a-z\d_](?:[a-z\d_-]*[a-z\d])?))
(?:(?&subpart)\.)*
(?&part)
(?:\.[a-z]+|\.xn--[a-z\d]+){1,2}
$/igm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^
(?(DEFINE)(?<part>(?:xn--)?[a-z\\d](?:[a-z\\d-]*[a-z\\d])?))
(?(DEFINE)(?<subpart>(?:xn--)?[a-z\\d_](?:[a-z\\d_-]*[a-z\\d])?))
(?:(?&subpart)\\.)*
(?&part)
(?:\\.[a-z]+|\\.xn--[a-z\\d]+){1,2}
$', 'igm')
const str = `www.foo.bar.baz
www.foo.bar
foo.bar.baz
foo.bar
foo
xn--tst-qla.de
xn--tst-qla.xn--tst-qla.de
xn--tst-qla.xn--tstqla
ASPMX.L.GOOGLE.COM
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}