$re = '/^
(?(DEFINE)(?<part>(?:xn--)?[a-z\d](?:[a-z\d-]*[a-z\d])?))
(?(DEFINE)(?<subpart>(?:xn--)?[a-z\d_](?:[a-z\d_-]*[a-z\d])?))
(?:(?&subpart)\.)*
(?&part)
(?:\.[a-z]+|\.xn--[a-z\d]+){1,2}
$/xim';
$str = 'www.foo.bar.baz
www.foo.bar
foo.bar.baz
foo.bar
foo
xn--tst-qla.de
xn--tst-qla.xn--tst-qla.de
xn--tst-qla.xn--tstqla
ASPMX.L.GOOGLE.COM
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);