using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[,]{1}[\s]*?\""attr\""[ ]*?[:][ ]*?\"".*\""[^,]|\""attr\""[ ]*?[:][ ]*?\"".*\""[,]{0,1}";
string input = @"{
""attr"": ""MYVALUE"",
""anotherAttr0"": ""foobar"",
""attr"": ""MYVALUE2"",
""anotherAttr1"": false,
""anotherAttr2"": ""300"",
""attr"": ""MYVALUE3""
}";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}