import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[,]{1}[\\s]*?\\\"attr\\\"[ ]*?[:][ ]*?\\\".*\\\"[^,]|\\\"attr\\\"[ ]*?[:][ ]*?\\\".*\\\"[,]{0,1}";
final String string = "{\n"
+ " \"attr\": \"MYVALUE\",\n"
+ " \"anotherAttr0\": \"foobar\",\n"
+ " \"attr\": \"MYVALUE2\",\n"
+ " \"anotherAttr1\": false,\n"
+ " \"anotherAttr2\": \"300\",\n"
+ " \"attr\": \"MYVALUE3\"\n"
+ "}";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}