import re
regex = re.compile(r"[,]{1}[\s]*?\"attr\"[ ]*?[:][ ]*?\".*\"[^,]|\"attr\"[ ]*?[:][ ]*?\".*\"[,]{0,1}")
test_str = ("{\n"
" \"attr\": \"MYVALUE\",\n"
" \"anotherAttr0\": \"foobar\",\n"
" \"attr\": \"MYVALUE2\",\n"
" \"anotherAttr1\": false,\n"
" \"anotherAttr2\": \"300\",\n"
" \"attr\": \"MYVALUE3\"\n"
"}")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")