// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"[,]{1}[\s]*?\"attr\"[ ]*?[:][ ]*?\".*\"[^,]|\"attr\"[ ]*?[:][ ]*?\".*\"[,]{0,1}"#).unwrap();
let string = "{
\"attr\": \"MYVALUE\",
\"anotherAttr0\": \"foobar\",
\"attr\": \"MYVALUE2\",
\"anotherAttr1\": false,
\"anotherAttr2\": \"300\",
\"attr\": \"MYVALUE3\"
}";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}