re = /[,]{1}[\s]*?\"attr\"[ ]*?[:][ ]*?\".*\"[^,]|\"attr\"[ ]*?[:][ ]*?\".*\"[,]{0,1}/
str = '{
"attr": "MYVALUE",
"anotherAttr0": "foobar",
"attr": "MYVALUE2",
"anotherAttr1": false,
"anotherAttr2": "300",
"attr": "MYVALUE3"
}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end