#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?i)^(?:https?:\/\/)(?:w{3}\.)?([^\r\n]+?)\.([a-z0-9]{2,6}(?:\.[a-z0-9]{2,6})?)\/?(.*)$"
Local $sString = "https://stackoverflow.com/questions/ask" & @CRLF & _
"https://stackoverflow.co.uk/questions/ask" & @CRLF & _
"https://www.stackoverflow.com/questions/ask" & @CRLF & _
"http://www.stackoverflow.co.uk/questions/ask" & @CRLF & _
"http://www.stackoverflow.co.uk/" & @CRLF & _
"http://www.stackoverflow.co.uk"
Local $sSubst = "\2/\1/\3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)