import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i)^(?:https?:\\/\\/)(?:w{3}\\.)?([^\\r\\n]+?)\\.([a-z0-9]{2,6}(?:\\.[a-z0-9]{2,6})?)\\/?(.*)$";
final String string = "https://stackoverflow.com/questions/ask\n"
+ "https://stackoverflow.co.uk/questions/ask\n"
+ "https://www.stackoverflow.com/questions/ask\n"
+ "http://www.stackoverflow.co.uk/questions/ask\n"
+ "http://www.stackoverflow.co.uk/\n"
+ "http://www.stackoverflow.co.uk";
final String subst = "\\2/\\1/\\3";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}