const regex = /(?i)^(?:https?:\/\/)(?:w{3}\.)?([^\r\n]+?)\.([a-z0-9]{2,6}(?:\.[a-z0-9]{2,6})?)\/?(.*)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?i)^(?:https?:\\\/\\\/)(?:w{3}\\.)?([^\\r\\n]+?)\\.([a-z0-9]{2,6}(?:\\.[a-z0-9]{2,6})?)\\\/?(.*)$', 'gm')
const str = `https://stackoverflow.com/questions/ask
https://stackoverflow.co.uk/questions/ask
https://www.stackoverflow.com/questions/ask
http://www.stackoverflow.co.uk/questions/ask
http://www.stackoverflow.co.uk/
http://www.stackoverflow.co.uk`;
const subst = `\2/\1/\3`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);