import re
regex = re.compile(r"(?i)^(?:https?:\/\/)(?:w{3}\.)?([^\r\n]+?)\.([a-z0-9]{2,6}(?:\.[a-z0-9]{2,6})?)\/?(.*)$", flags=re.MULTILINE)
test_str = ("https://stackoverflow.com/questions/ask\n"
"https://stackoverflow.co.uk/questions/ask\n"
"https://www.stackoverflow.com/questions/ask\n"
"http://www.stackoverflow.co.uk/questions/ask\n"
"http://www.stackoverflow.co.uk/\n"
"http://www.stackoverflow.co.uk")
subst = "\\2/\\1/\\3"
result = regex.sub(subst, test_str)
if result:
print(result)