using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(one=[^\s]*?\/)|(two=[^\s]*?\/)";
string input = @"https://m.media-amazon.com/one=hjhjhjhjhjhj/I/91uq+v1wOFL._AC_UY218_.jpg"" class=""s-image"" alt=""Doom - PC"" https://m.media-amazon.com/images/I/two=sdsdsds/";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}