const regex = /(one=[^\s]*?\/)|(two=[^\s]*?\/)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(one=[^\\s]*?\\\/)|(two=[^\\s]*?\\\/)', 'gm')
const str = `https://m.media-amazon.com/one=hjhjhjhjhjhj/I/91uq+v1wOFL._AC_UY218_.jpg" class="s-image" alt="Doom - PC" https://m.media-amazon.com/images/I/two=sdsdsds/`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}