$re = '/(one=[^\s]*?\/)|(two=[^\s]*?\/)/m';
$str = 'https://m.media-amazon.com/one=hjhjhjhjhjhj/I/91uq+v1wOFL._AC_UY218_.jpg" class="s-image" alt="Doom - PC" https://m.media-amazon.com/images/I/two=sdsdsds/';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);