package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(one=[^\s]*?\/)|(two=[^\s]*?\/)`)
var str = `https://m.media-amazon.com/one=hjhjhjhjhjhj/I/91uq+v1wOFL._AC_UY218_.jpg" class="s-image" alt="Doom - PC" https://m.media-amazon.com/images/I/two=sdsdsds/`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}