// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(one=[^\s]*?\/)|(two=[^\s]*?\/)").unwrap();
let string = "https://m.media-amazon.com/one=hjhjhjhjhjhj/I/91uq+v1wOFL._AC_UY218_.jpg\" class=\"s-image\" alt=\"Doom - PC\" https://m.media-amazon.com/images/I/two=sdsdsds/";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}