using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<template id=""(.*)"" [^>]+>(.*?)<\/template>";
string input = @"<template id=""tpl-pagination-item"" type=""crinja""> {% for page in pages %}<li class=""page-item{% if page==current_page %} active{% endif %}""> <a class=""page-link"" href=""/{{view}}/?p={{page}}{%for k,v in query%}&{{k}}={{v}}{%endfor%}"" onclick=""event.preventDefault();""> {{page}} </a> </li>{% endfor %}</template><template id=""tpl-pagination"" for=""base""> <nav aria-label=""Page navigation"" class=""w-100 mt-3""> <ul class=""pagination justify-content-center"">${() => props.pages().map(page => html` <li class=""page-item${() => page==props.currentPage() ? ' active' : ''}""> <a class=""page-link"" href=""/${props.view}/?p=${page}"" onclick=""${(e) => {e.preventDefault(); props.callback(page);}}"">${page}</a> </li>`)} </ul> </nav></template>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}