import Foundation
let pattern = #"<template id="(.*)" [^>]+>(.*?)<\/template>"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"<template id="tpl-pagination-item" type="crinja"> {% for page in pages %}<li class="page-item{% if page==current_page %} active{% endif %}"> <a class="page-link" href="/{{view}}/?p={{page}}{%for k,v in query%}&{{k}}={{v}}{%endfor%}" onclick="event.preventDefault();"> {{page}} </a> </li>{% endfor %}</template><template id="tpl-pagination" for="base"> <nav aria-label="Page navigation" class="w-100 mt-3"> <ul class="pagination justify-content-center">${() => props.pages().map(page => html` <li class="page-item${() => page==props.currentPage() ? ' active' : ''}"> <a class="page-link" href="/${props.view}/?p=${page}" onclick="${(e) => {e.preventDefault(); props.callback(page);}}">${page}</a> </li>`)} </ul> </nav></template>"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)