$re = '/<template id="(.*)" [^>]+>(.*?)<\/template>/m';
$str = '<template id="tpl-pagination-item" type="crinja"> {% for page in pages %}<li class="page-item{% if page==current_page %} active{% endif %}"> <a class="page-link" href="/{{view}}/?p={{page}}{%for k,v in query%}&{{k}}={{v}}{%endfor%}" onclick="event.preventDefault();"> {{page}} </a> </li>{% endfor %}</template><template id="tpl-pagination" for="base"> <nav aria-label="Page navigation" class="w-100 mt-3"> <ul class="pagination justify-content-center">${() => props.pages().map(page => html` <li class="page-item${() => page==props.currentPage() ? \' active\' : \'\'}"> <a class="page-link" href="/${props.view}/?p=${page}" onclick="${(e) => {e.preventDefault(); props.callback(page);}}">${page}</a> </li>`)} </ul> </nav></template>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);