package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<template id="(.*)" [^>]+>(.*?)<\/template>`)
var str = `<template id="tpl-pagination-item" type="crinja"> {% for page in pages %}<li class="page-item{% if page==current_page %} active{% endif %}"> <a class="page-link" href="/{{view}}/?p={{page}}{%for k,v in query%}&{{k}}={{v}}{%endfor%}" onclick="event.preventDefault();"> {{page}} </a> </li>{% endfor %}</template><template id="tpl-pagination" for="base"> <nav aria-label="Page navigation" class="w-100 mt-3"> <ul class="pagination justify-content-center">${() => props.pages().map(page => html\` <li class="page-item${() => page==props.currentPage() ? ' active' : ''}"> <a class="page-link" href="/${props.view}/?p=${page}" onclick="${(e) => {e.preventDefault(); props.callback(page);}}">${page}</a> </li>\`)} </ul> </nav></template>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}