const regex = /<template id="(.*)" [^>]+>(.*?)<\/template>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<template id="(.*)" [^>]+>(.*?)<\\\/template>', 'gm')
const str = `<template id="tpl-pagination-item" type="crinja"> {% for page in pages %}<li class="page-item{% if page==current_page %} active{% endif %}"> <a class="page-link" href="/{{view}}/?p={{page}}{%for k,v in query%}&{{k}}={{v}}{%endfor%}" onclick="event.preventDefault();"> {{page}} </a> </li>{% endfor %}</template><template id="tpl-pagination" for="base"> <nav aria-label="Page navigation" class="w-100 mt-3"> <ul class="pagination justify-content-center">\${() => props.pages().map(page => html\` <li class="page-item\${() => page==props.currentPage() ? ' active' : ''}"> <a class="page-link" href="/\${props.view}/?p=\${page}" onclick="\${(e) => {e.preventDefault(); props.callback(page);}}">\${page}</a> </li>\`)} </ul> </nav></template>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}