import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "public \\w*\\s*class (.+)\\.(\\w+) \\{\\n([^\\}]*)\\}$";
final String string = "Compiled from \"Test.kt\"\n"
+ "public final class com.github.animeshz.keyboard.jni.Test {\n"
+ " public final native void test(kotlinx.coroutines.flow.Flow<java.lang.Integer>);\n"
+ " public com.github.animeshz.keyboard.jni.Test();\n"
+ "}\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}