$re = '/public \w*\s*class (.+)\.(\w+) \{\n([^\}]*)\}$/';
$str = 'Compiled from "Test.kt"
public final class com.github.animeshz.keyboard.jni.Test {
public final native void test(kotlinx.coroutines.flow.Flow<java.lang.Integer>);
public com.github.animeshz.keyboard.jni.Test();
}
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);