// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"public \w*\s*class (.+)\.(\w+) \{\n([^\}]*)\}$").unwrap();
let string = "Compiled from \"Test.kt\"
public final class com.github.animeshz.keyboard.jni.Test {
public final native void test(kotlinx.coroutines.flow.Flow<java.lang.Integer>);
public com.github.animeshz.keyboard.jni.Test();
}
";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}