re = /public \w*\s*class (.+)\.(\w+) \{\n([^\}]*)\}$/
str = 'Compiled from "Test.kt"
public final class com.github.animeshz.keyboard.jni.Test {
public final native void test(kotlinx.coroutines.flow.Flow<java.lang.Integer>);
public com.github.animeshz.keyboard.jni.Test();
}
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end