using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^.]\s([A-Z]\w+)";
string input = @"This is a Test sentence. The sentence is Supposed to Ignore the Words at the beginning of the Sentence, And others.";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}