re = /[^.]\s([A-Z]\w+)/
str = 'This is a Test sentence. The sentence is Supposed to Ignore the Words at the beginning of the Sentence, And others.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end