// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"[^.]\s([A-Z]\w+)").unwrap();
let string = "This is a Test sentence. The sentence is Supposed to Ignore the Words at the beginning of the Sentence, And others.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}