package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[^.]\s([A-Z]\w+)`)
var str = `This is a Test sentence. The sentence is Supposed to Ignore the Words at the beginning of the Sentence, And others.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}