$re = '/[^.]\s([A-Z]\w+)/';
$str = 'This is a Test sentence. The sentence is Supposed to Ignore the Words at the beginning of the Sentence, And others.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);