#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(-L)(\d)"
Local $sString = "Sa-L1" & @CRLF & _
"Sa-L23"
Local $sSubst = "$1-$2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)