use strict;
my $str = 'Sa-L1
Sa-L23';
my $regex = qr/(-L)(\d)/mp;
my $subst = '$1-$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";