$re = '/(-L)(\d)/m';
$str = 'Sa-L1
Sa-L23';
$subst = "$1-$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;