package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(-L)(\d)`)
var str = `Sa-L1
Sa-L23`
var substitution = "$1-$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}