const regex = /(-L)(\d)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(-L)(\\d)', 'gm')
const str = `Sa-L1
Sa-L23`;
const subst = `$1-$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);