#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?P<TYPE>^\.+\w*)+=+(?P<Programm>\S+)"
Local $sString = "C:\Users\Игорь>Assoc" & @CRLF & _
".001=WinRAR" & @CRLF & _
".386=vxdfile" & @CRLF & _
".3ds=Photoshop.3DSFileType.150" & @CRLF & _
".3g2=WMP11.AssocFile.3G2" & @CRLF & _
".3gp=WMP11.AssocFile.3GP" & @CRLF & _
".3gp2=WMP11.AssocFile.3G2" & @CRLF & _
".3gpp=WMP11.AssocFile.3GP" & @CRLF & _
".7z=WinRAR" & @CRLF & _
".8ba=Photoshop.PlugIn" & @CRLF & _
".8bc=Photoshop.PlugIn" & @CRLF & _
".8be=Photoshop.PlugIn" & @CRLF & _
".8bf=Photoshop.PlugIn" & @CRLF & _
".8bi=Photoshop.PlugIn" & @CRLF & _
".8bp=Photoshop.PlugIn" & @CRLF & _
".8bs=Photoshop.PlugIn" & @CRLF & _
".8bx=Photoshop.PlugIn" & @CRLF & _
".8by=Photoshop.PlugIn" & @CRLF & _
".8li=Photoshop.PlugIn" & @CRLF & _
".AAC=WMP11.AssocFile.ADTS" & @CRLF & _
".abr=Photoshop.BrushesFile" & @CRLF & _
".acb=Photoshop.ColorBooks" & @CRLF & _
".accountpicture-ms=accountpicturefile" & @CRLF & _
".acf=Photoshop.CustomFilterKernel" & @CRLF & _
".acl=ACLFile" & @CRLF & _
".aco=Photoshop.SwatchesFile" & @CRLF & _
".act=Photoshop.ColorTableFile" & @CRLF & _
".acv=Photoshop.CurvesFile" & @CRLF & _
".ado=Photoshop.DuotoneSettingsFile" & @CRLF & _
".ADT=WMP11.AssocFile.ADTS" & @CRLF & _
".ADTS=WMP11.AssocFile.ADTS" & @CRLF & _
".ahs=Photoshop.HalftoneScreens" & @CRLF & _
".ahu=Photoshop.HueSatFile" & @CRLF & _
".aif=WMP11.AssocFile.AIFF" & @CRLF & _
".aifc=WMP11.AssocFile.AIFF" & @CRLF & _
".aiff=WMP11.AssocFile.AIFF" & @CRLF & _
".alv=Photoshop.LevelsFile" & @CRLF & _
".amp=Photoshop.ArbitraryMapFile" & @CRLF & _
".ams=Photoshop.MonitorSetupFile"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")