const regex = new RegExp('(?P<TYPE>^\\.+\\w*)+=+(?P<Programm>\\S+)', 'gm')
const str = `C:\\Users\\Игорь>Assoc
.001=WinRAR
.386=vxdfile
.3ds=Photoshop.3DSFileType.150
.3g2=WMP11.AssocFile.3G2
.3gp=WMP11.AssocFile.3GP
.3gp2=WMP11.AssocFile.3G2
.3gpp=WMP11.AssocFile.3GP
.7z=WinRAR
.8ba=Photoshop.PlugIn
.8bc=Photoshop.PlugIn
.8be=Photoshop.PlugIn
.8bf=Photoshop.PlugIn
.8bi=Photoshop.PlugIn
.8bp=Photoshop.PlugIn
.8bs=Photoshop.PlugIn
.8bx=Photoshop.PlugIn
.8by=Photoshop.PlugIn
.8li=Photoshop.PlugIn
.AAC=WMP11.AssocFile.ADTS
.abr=Photoshop.BrushesFile
.acb=Photoshop.ColorBooks
.accountpicture-ms=accountpicturefile
.acf=Photoshop.CustomFilterKernel
.acl=ACLFile
.aco=Photoshop.SwatchesFile
.act=Photoshop.ColorTableFile
.acv=Photoshop.CurvesFile
.ado=Photoshop.DuotoneSettingsFile
.ADT=WMP11.AssocFile.ADTS
.ADTS=WMP11.AssocFile.ADTS
.ahs=Photoshop.HalftoneScreens
.ahu=Photoshop.HueSatFile
.aif=WMP11.AssocFile.AIFF
.aifc=WMP11.AssocFile.AIFF
.aiff=WMP11.AssocFile.AIFF
.alv=Photoshop.LevelsFile
.amp=Photoshop.ArbitraryMapFile
.ams=Photoshop.MonitorSetupFile`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}