package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?P<TYPE>^\.+\w*)+=+(?P<Programm>\S+)`)
var str = `C:\Users\Игорь>Assoc
.001=WinRAR
.386=vxdfile
.3ds=Photoshop.3DSFileType.150
.3g2=WMP11.AssocFile.3G2
.3gp=WMP11.AssocFile.3GP
.3gp2=WMP11.AssocFile.3G2
.3gpp=WMP11.AssocFile.3GP
.7z=WinRAR
.8ba=Photoshop.PlugIn
.8bc=Photoshop.PlugIn
.8be=Photoshop.PlugIn
.8bf=Photoshop.PlugIn
.8bi=Photoshop.PlugIn
.8bp=Photoshop.PlugIn
.8bs=Photoshop.PlugIn
.8bx=Photoshop.PlugIn
.8by=Photoshop.PlugIn
.8li=Photoshop.PlugIn
.AAC=WMP11.AssocFile.ADTS
.abr=Photoshop.BrushesFile
.acb=Photoshop.ColorBooks
.accountpicture-ms=accountpicturefile
.acf=Photoshop.CustomFilterKernel
.acl=ACLFile
.aco=Photoshop.SwatchesFile
.act=Photoshop.ColorTableFile
.acv=Photoshop.CurvesFile
.ado=Photoshop.DuotoneSettingsFile
.ADT=WMP11.AssocFile.ADTS
.ADTS=WMP11.AssocFile.ADTS
.ahs=Photoshop.HalftoneScreens
.ahu=Photoshop.HueSatFile
.aif=WMP11.AssocFile.AIFF
.aifc=WMP11.AssocFile.AIFF
.aiff=WMP11.AssocFile.AIFF
.alv=Photoshop.LevelsFile
.amp=Photoshop.ArbitraryMapFile
.ams=Photoshop.MonitorSetupFile`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}