import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?P<TYPE>^\\.+\\w*)+=+(?P<Programm>\\S+)";
final String string = "C:\\Users\\Игорь>Assoc\n"
+ ".001=WinRAR\n"
+ ".386=vxdfile\n"
+ ".3ds=Photoshop.3DSFileType.150\n"
+ ".3g2=WMP11.AssocFile.3G2\n"
+ ".3gp=WMP11.AssocFile.3GP\n"
+ ".3gp2=WMP11.AssocFile.3G2\n"
+ ".3gpp=WMP11.AssocFile.3GP\n"
+ ".7z=WinRAR\n"
+ ".8ba=Photoshop.PlugIn\n"
+ ".8bc=Photoshop.PlugIn\n"
+ ".8be=Photoshop.PlugIn\n"
+ ".8bf=Photoshop.PlugIn\n"
+ ".8bi=Photoshop.PlugIn\n"
+ ".8bp=Photoshop.PlugIn\n"
+ ".8bs=Photoshop.PlugIn\n"
+ ".8bx=Photoshop.PlugIn\n"
+ ".8by=Photoshop.PlugIn\n"
+ ".8li=Photoshop.PlugIn\n"
+ ".AAC=WMP11.AssocFile.ADTS\n"
+ ".abr=Photoshop.BrushesFile\n"
+ ".acb=Photoshop.ColorBooks\n"
+ ".accountpicture-ms=accountpicturefile\n"
+ ".acf=Photoshop.CustomFilterKernel\n"
+ ".acl=ACLFile\n"
+ ".aco=Photoshop.SwatchesFile\n"
+ ".act=Photoshop.ColorTableFile\n"
+ ".acv=Photoshop.CurvesFile\n"
+ ".ado=Photoshop.DuotoneSettingsFile\n"
+ ".ADT=WMP11.AssocFile.ADTS\n"
+ ".ADTS=WMP11.AssocFile.ADTS\n"
+ ".ahs=Photoshop.HalftoneScreens\n"
+ ".ahu=Photoshop.HueSatFile\n"
+ ".aif=WMP11.AssocFile.AIFF\n"
+ ".aifc=WMP11.AssocFile.AIFF\n"
+ ".aiff=WMP11.AssocFile.AIFF\n"
+ ".alv=Photoshop.LevelsFile\n"
+ ".amp=Photoshop.ArbitraryMapFile\n"
+ ".ams=Photoshop.MonitorSetupFile";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}