using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\h*(?<!`)<\?(\w+)\h*([^\v]*)\v*(.*?)\s*\?>";
string input = @"<x-section markdown=""1"" name=""heros"">
<x-container markdown=""1"" title=""Heros"" class=""decorate-left prose"">
{.lead}Heros are the header shown at the top of each page.
<?md class=""asdf""
asdf
asdf
?>
<div><?md
asdf
?>
<?md x=""y""
asdf
?>
They get `<?md` inserted automatically for you. Nothing extra to do here.
The only requirement is to set a `hero` key in the Front Matter for your page.
";
RegexOptions options = RegexOptions.Multiline | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}