const regex = /\h*(?<!`)<\?(\w+)\h*([^\v]*)\v*(.*?)\s*\?>/gms;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\h*(?<!`)<\\?(\\w+)\\h*([^\\v]*)\\v*(.*?)\\s*\\?>', 'gms')
const str = `<x-section markdown="1" name="heros">
<x-container markdown="1" title="Heros" class="decorate-left prose">
{.lead}Heros are the header shown at the top of each page.
<?md class="asdf"
asdf
asdf
?>
<div><?md
asdf
?>
<?md x="y"
asdf
?>
They get \`<?md\` inserted automatically for you. Nothing extra to do here.
The only requirement is to set a \`hero\` key in the Front Matter for your page.
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}