use strict;
my $str = '<x-section markdown="1" name="heros">
<x-container markdown="1" title="Heros" class="decorate-left prose">
{.lead}Heros are the header shown at the top of each page.
<?md class="asdf"
asdf
asdf
?>
<div><?md
asdf
?>
<?md x="y"
asdf
?>
They get `<?md` inserted automatically for you. Nothing extra to do here.
The only requirement is to set a `hero` key in the Front Matter for your page.
';
my $regex = qr/\h*(?<!`)<\?(\w+)\h*([^\v]*)\v*(.*?)\s*\?>/msp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}