import Foundation
let pattern = #"\h*(?<!`)<\?(\w+)\h*([^\v]*)\v*(.*?)\s*\?>"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .dotMatchesLineSeparators])
let testString = #"""
<x-section markdown="1" name="heros">
<x-container markdown="1" title="Heros" class="decorate-left prose">
{.lead}Heros are the header shown at the top of each page.
<?md class="asdf"
asdf
asdf
?>
<div><?md
asdf
?>
<?md x="y"
asdf
?>
They get `<?md` inserted automatically for you. Nothing extra to do here.
The only requirement is to set a `hero` key in the Front Matter for your page.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)