import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\h*(?<!`)<\\?(\\w+)\\h*([^\\v]*)\\v*(.*?)\\s*\\?>";
final String string = "<x-section markdown=\"1\" name=\"heros\">\n"
+ "<x-container markdown=\"1\" title=\"Heros\" class=\"decorate-left prose\">\n"
+ "{.lead}Heros are the header shown at the top of each page.\n\n"
+ " <?md class=\"asdf\"\n"
+ " asdf\n"
+ " asdf\n"
+ " ?>\n\n"
+ " <div><?md\n"
+ " asdf\n"
+ " ?>\n\n"
+ "<?md x=\"y\"\n\n"
+ " asdf\n\n"
+ "?>\n\n"
+ "They get `<?md` inserted automatically for you. Nothing extra to do here.\n\n"
+ "The only requirement is to set a `hero` key in the Front Matter for your page.\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}