const regex = /\b(\(?0?\d{2}\)?)?\s?9[\s\-]?\d{4}[\s\-]?\d{4}\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(\\(?0?\\d{2}\\)?)?\\s?9[\\s\\-]?\\d{4}[\\s\\-]?\\d{4}\\b', 'gm')
const str = `O meu numero de telefone é 991234567 e não mudou
O meu numero de telefone é 11991234567 e não mudou
O meu numero de telefone é 11 99123 4567 e não mudou
O meu numero de telefone é 11 9 9123 4567 e não mudou
O meu numero de telefone é (11)991234567 e não mudou
O meu numero de telefone é (11) 9 9123 4567 e não mudou
O número 3393333333333333 não é um numero valido
O número 22 2 2222 2222 não é um numero valido
O meu numero de telefone é 9 9123-4567 e não mudou
O meu numero de telefone é 11 99123-4567 e não mudou
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}